• Problème avec la bourse


    Bonjour , j’ai voulu ajouté à mon serveur la bourse dynamique.

    Pour sa , j’ai suivi le tutoriel de Apocalyptos : https://altisdev.com/topic/6373/bourse-dynamique-4-4 ( Qui est très bien expliqué)

    Mais il s’avère que quand je suis en jeu et que je clique sur bourse , sa m’affiche donc le menu et sa me met “Calcul des prix en cours…” puis il ne se passe rien.

    Logs

  • https://github.com/RyanTT/DynamicMarket/tree/29eec6d52f01b63bbe61e9fa87fe0458c83c758e/DynMarket (ALTISLIFE 4.4r3)
    et aussi

    18:09:35 Error in expression <syncCall;
    };
    };
    master_group attachTo[bank_obj,[0,0,0]];
    {
    _hs = createVehicl>
    18:09:35 Error position: <bank_obj,[0,0,0]];
    {
    _hs = createVehicl>
    18:09:35 Error Undefined variable in expression: bank_obj
    18:09:35 File life_server\init.sqf, line 84

  • @Sergueiii’

    C’est juste qu’il reconnait pas la variable bank_obj dans le mapping ?
    Ou c’est pas du tout sa et je dois juste supprimer la ligne “master_group attachTo[bank_obj,[0,0,0]];” ?

  • Surtout pas, vérifie que tu as bien l’objet sur la map.

  • C’est juste la bank federal ca … non ?
    regarde ton script fn_virt_sell.sqf y a une erreur c est dans tes logs
    18:09:33 Error in expression <,"_price","_amount","_name"];
    if(EQUAL(lbCurSel 2402,-1)) exitWith {};
    _type>
    18:09:33 Error position: <(lbCurSel 2402,-1)) exitWith {};
    _type>
    18:09:33 Error Missing )
    18:09:33 File mpmissions\Altis_Life.Stratis\core\shops\fn_virt_sell.sqf, line 10
    18:09:33 Error in expression <,"_price","_amount","_name"];
    if(EQUAL(lbCurSel 2402,-1)) exitWith {};
    _type>
    18:09:33 Error position: <(lbCurSel 2402,-1)) exitWith {};
    _type>
    18:09:33 Error Missing )

    C est pour ca que j aime pas les tutos ou y a ecrit “Remplacer tout par:”

  • @brutalzic a dit dans Problème avec la bourse :

    C’est juste la bank federal ca … non ?

    C’est l’objet de l’île de spawn oui, mais c’est toujours mieux de régler tous les bugs avant de rajouter du contenu.

  • @Sergueiii’

    @Sergueiii' a dit dans Problème avec la bourse :

    Surtout pas, vérifie que tu as bien l’objet sur la map.

    Je ne possède pas l’objet sur la map. Est-ce grave ? Si oui comment je pourrais me le procurer ?

  • @Xoasise a dit dans Problème avec la bourse :

    @Sergueiii' a dit dans Problème avec la bourse :

    Surtout pas, vérifie que tu as bien l’objet sur la map.

    Je ne possède pas l’objet sur la map. Est-ce grave ? Si oui comment je pourrais me le procurer ?

    Tu peux regarder sur un mission.sqm frais, puis recopier l’init et l’objet dans ta mission.

  • @Sergueiii’

    Ok , j’ai regarder dans un mission.sqm frais j’ai copier l’objet pour le mettre dans ma mission (par contre dans l’init il y a rien) puis j’ai lancer le serv.

    Je pense que le problème du bank_obj est réglé je te montre les logs.

    Logs

  • Non c est pas grave su tu veux pas de bank federal !

  • 12:21:10 Scripting function ‘ton_fnc_playerlogged’ is not allowed to be remotely executed

    @brutalzic à ce moment là faut virer tout ce qui est en lien avec la banque.

  • C est plus propre @Sergueiii mais cela ne causera pas de bug.

  • Merci à tout ceux qui m’on aidé , j’ai résolu le problème.

    J’avais tout simplement oublier de re-pack le life_server.pbo.

  • C est malin ça ! :)
    Meme ma mission je la place en pbo a chaque fois !

Messages 14Vues 1641

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.