• Probleme apres ajout OPFOR


    Salut tout le monde, je suis actuellement entrain d’ajouter les OPFOR sur mon serveur et j’ai quelques probleme, un en particulier.
    Je sais que le serveur n’arrive pas a communiquer avec la DB, le dernier ajout de ma part étant les OPFOR je suis donc certain que c’est du a sa.
    De plus sur les logs j’ai cette erreur

    extDB3: SQL: Error MariaDBQueryException: Column count doesn't match value count at row 1
    [12:42:28:581915 +01:00] [Thread 10308] extDB3: SQL: Error MariaDBQueryException: Input: INSERT INTO players (pid, name, cash, bankacc, aliases, cop_licenses, med_licenses, civ_licenses, civ_gear, cop_gear, med_gear, adac_gear, adac_licenses) VALUES('76561198031132070', 'Mon Pseudo', '0', '80000', '"[`Mon Pseudo`]"','"[]"','"[]"','"[]"','"[]"','"[]"','"[]"')
    
    

    D’après ce que j’en déduit c’est qu’il manque des colonnes dans ma DB ce qui fait que le serveur ne peut pas écrire dans les emplacement manquant.

    Quand je me connecte j’arrive dans le lobby, choisi ma place, je clique OK une barre de chargement réparé mais sans chiffre (Ko), j’arrive sur la carte clique encore sur ok et la j’ai une erreur

    Le serveur n'a pas trouvé toutes les informations de lecteur correspondant a votre UID
    

    Ce qui pour moi correspondrais avec l’erreur dans les log DB.

    Je suis sur un 5.0 Tanoa, DB en extDB3 64bits qui fonctionner très bien avant l’ajout des OPFOR.

    Avez vous déjà eu une tel erreur ?

    Log DB: https://pastebin.com/JNUG1kLB

    Pour ce qui est des log serveur (RPT) aucun soucis a ce niveau juste des erreur au niveau des addons déjà la avant le probleme

    Merci a vous

    PS: Oui j’ai bien remis en PBO le life serveur

  • @aqua a dit dans Probleme apres ajout OPFOR :

    t doe

    Tu a 13 requête a envoyez, mais tu lui donne 11 valeur

    Discord : https://discord.gg/CqN7ETt

    "Toi, le bon Dieu, au lieu de te donner un cerveau, il aurait mieux fait de te creuser un deuxième trou du cul, parce que tu chies plus que tu penses ! "

  • en gros j’ai juste a ajouter des “[]” ?

  • @Aqua le serveur attend de recevoir 13 valeurs. Avec ta requête, tu ne lui renvoies que 11 valeurs. Il manque donc 2 valeurs à ta requête.

    Modérateur AltisDev - Développeur SQF / SQL / C++ / C#
    Développeur chez Impulsion Life
    Discord
    https://discord.gg/3A2NmWd

  • Bonsoir j’avais bien compris le probleme mais je n’était pas sur de se qu’il fallais ajouter.

    J’ai maintenant un autre message d’erreur : Demande reçue du serveur… Validation.

    Encore une fois je pense que c’est la liaison avec la db mais comparer a tout a l’heure mes slots civil policier et medic fonctionne, il n’y a que mes slots OPFOR qui ne fonctionne pas.

    Niveau log rien a signaler plus d’erreur dans la db ni dans les RPT

  • Logs quand même ?

    Contact :
    - TS : ts.the-programmer.com
    - Discord : https://discord.gg/DhFUFsq

  • Tu veut les log de quel coté ?

  • Db et serveur quand tu essayes de te connecter en opfor

    Contact :
    - TS : ts.the-programmer.com
    - Discord : https://discord.gg/DhFUFsq

  • log Serveur https://pastebin.com/R1WQQBgE
    log DB https://pastebin.com/XprsMJkA

    Par contre je ne sais pas si tu a déjà eu le soucis mais j’ai désactiver spyglass dans config master mais celui-ci est toujours actif idem pour mes canaux vocaux et ecrit in game (je peut créer un autre poste si jamais)

  • C’est normal ça :
    Server error: Player without identity Magui Bolle (id 1398302556)

    Contact :
    - TS : ts.the-programmer.com
    - Discord : https://discord.gg/DhFUFsq

  • J’ai eu cette erreur sur le slots civil aussi, pense tu que si je wipe la DB sa pourrais arranger les choses ?

  • Voici un log sans mod: https://pastebin.com/SXP1LZif

  • Essaye de supprimer ta ligne dans la bdd car l’erreur y est toujours…

    Contact :
    - TS : ts.the-programmer.com
    - Discord : https://discord.gg/DhFUFsq

  • Bon j’ai wipe ma DB, même résultat https://pastebin.com/H61ynkyq.

    Je me suis rendu compte de quelque chose, quand je spawn et que j’ai l’écran me disant que le serveur envois les donner, bien j’entends tiré le perso quand je fait clique gauche

  • Donc apres avoir fait des recherche sur ce probleme je me suis rendu compte que les personnes qui en sont victime on tous sa dans leurs log

    
     8:16:19 Mission Altis_Life.Altis: ‘description.ext::Header::minPlayer’ (0) is wrong
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:21 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
     8:16:22 Server error: Player without identity  (id 1309343755)
    
    
  • Essaye de recréer ton identitée arma ?

    Contact :
    - TS : ts.the-programmer.com
    - Discord : https://discord.gg/DhFUFsq

  • C’est a dire ?

  • ah oui, ouais je vais tester sa

  • Bon je vient de tester mais cela ne change rien

Messages 24Vues 809
Se connecter pour répondre