[RESOLUE] Menu Placble vide


#1

Bonjour,

Je rencontre un probléme que en Medic et cop le menu placable et vide

Ce que je fais

je clique et il est vide

Ce que je veux

Voir le menu placable rempli avec les cone et object mis dedans

Ce que j’obtiens

J’obtien un menu placable vide sans cone

Logs & infos complémentaires

Joignez les 3 types de logs suivants, même si vous ne jugez pas celui nécessaire, c’est imposé pour facilité l’aide :

Vous pouvez joindre vos logs en les mettant en ligne sur notre hastebin qui vous garantie confidentialité et anonymat.

Comment trouver ses logs ?
https://docs.altisdev.com/wiki/problemes-les-plus-communs/obtenir-ses-logs

Version du serveur : v3.1.4.8 ? v5 ? v4.4r3 ? 5.0
Système d’exploitation : Windows ? Linux ? Linux


#2


#3

@jerem2002

Salut a toi,

Pour commencer tu devrais appliquer et essayer tes scripts rajoutés sur une version “Vanilla” si je puis dire. Car tu as beaucoup de mods qui posent problème dans tes logs tu utilises des mots de plusieurs de serveur et de personne qui fait pas très bien leur travailles ce qui rapport des problèmes supplémentaires même si ce n’est pas l’origine du problème (enfin je suppose), essaye ton script sans mods, ni extension quelle-conque (Maps, Armes, Véhicule, Tout le reste quoi). Si l’erreur persiste fait le nous savoir. Good Luck.


#4

Dans un 1er temps, règle ta bdd ! Tu as énormément d’erreur, qui peuvent impacter ton serveur en tout point…
EXTDB3

Cependant tu as une erreur dans ton fichier placeable

Error in expression <ceables) - 1, _className];  
} foreach (life_placeables);  >
16:31:45   Error position: <life_placeables);  >
16:31:45   Error Variable indéfinie dans une expression: life_placeables
16:31:45 File core\placeables\fn_placeablesMenu.sqf [life_fnc_placeablesMenu], line 20

Envois ton fn_placeablesMenu.sqf

Il faut vraiment apprendre a lire vos logs … C’est n’importe quoi


#5

Aucuns rapport, lis les logs…


#6

Je n’ai pas dit directement que les mods créer un conflit mais qui pourrait être à l’origine d’autres erreurs. Merci à toi.


#7

@jerem2002, t as modifie le fn_placeablesInit.sqf ?
Si oui envoie le !

PS

Error Variable indéfinie dans une expression: life_placeables

C est donc qu il y a une erreur dans la creation de la variable, une “,” en trop ou oublier, un “;” manquant, …


#8

fn_placeablesInit : https://pastebin.com/H3v6HbH5
fn_placeablesMenu : https://pastebin.com/stxMydpN


#9

envoie ton core\fn_initCop.sqf et core\fn_initMedic.sqf


#10

fn_initMedic : https://pastebin.com/S96jfgZk
fn_initCop : https://pastebin.com/7asdCFK4


#11

Pas d erreur … refais le tuto de A a Z, a mon avis y a un point ou t as chier.

Pour commencer place le fn_placeablesInit de base fournis dans le tuto voir si sans tes modif ca fonctionne !


#12

Fonctionne Merci ! RESOLUE


#13

Un simple “resolu” ne dit pas au prochain qui passe sur ton post, quel etait le probleme.

1 - mettre le TAG resolu dans le titre, afin d aider la moderation a tenir le forum en ordre.
2 - une petite explication du comment tu as resolu ton probleme

MERCI


#14

J’ai tout simplement remis le PlacaebleInit de bases


#15

Ok, donc le probleme venait de tes modifs.

Il devait y avoir une erreur dans tes className des objets que tu avais selectionne, je ne voie pas d erreur de synthaxe dans ce que tu nous a fournie.
Quel mod a tu utilises ?


#16

Les Panneau CharlieCo89