[Résolu] Objectif : Placeables fonctionnel


#1

Avant de lire ce sujet sachez qu’il n’est pas la solution mais une tentative de faire en sorte qu’il marche.

Bonjour à tous, après avoir suivi à la lettre le tuto suivant : placeables. Je me suis rendu compte qu’il n’était pas fonctionnel (ou alors pas chez moi).

Ce que je fais

J’ai suivi dans un premier temps de le tut fourni par le Wiki.
Ensuite, un problème avec mon fichier placeables.hpp m’a empêché de lancé mon serveur en m’affichant un message d’erreur. Ce problème à été résolu grâce à l’aide de Brutalzic :
Lien.

J’ai également supprimé tous les espaces présent derrière chaque ligne, je ne sais pas si ça jour un rôle, mais au moins c’est fait.

Ce que je veux

Rendre fonctionnel les placeables.

Ce que j’obtiens

Pour l’instant, le bouton placeables s’affiche dans mon menu y mais quand je clique dessus, celui-ci se ferme mais rien ne s’ouvre

Voici les erreur que j’obtiens dans mes logs server avec la recherche placeables :


Logs

Fichier concerné

(Pourquoi j’ai tout mis, tout simplement comme ça ils sont à la disposition de tous et ça évitera d’attendre X heures si un fichier est nécessaire avant de pouvoir le fournir)

Version du serveur : V5
Système d’exploitation : Mission héberger chez Nitrado (Entraînement)

Je vous remercie pour le temps que vous avez consacrerez à la lecture.


#2

Je te conseille vivement d’arrêter de gâcher ta tune chez cet hébergeur si tu veux vraiment faire exclusivement du “Dev” sur celui-ci pour le moment je te conseille de créer un serveur en local ce qui est largement plus simple est plus fiable aussi. Concernant ta demande d’aide je n’ai pas la réponse. Bonne chance :wink: .


#3

Oui on me l’a déjà dit, dans 2 semaine je change mais merci


#4

Je regarderais a ton probleme dans le courant de la semaine ( je dois absolument formater mon pc )


#5

Perso, je te dirais, revoie tout !
Là y a une couille dans le pate. Avoir autant de probleme, c est qu il y a un truc qui va pas.
Avec quoi crees tu tes fichier quel editeur de texte ?


#6

De mémoire, il y a un problème avec les noms de fichiers, un s en trop où en moins il me semble vérifie sinon je regarde demain de plus près


#7

@brutalzic Je crée mes fichiers à l’aide du logiciel Atom

@tomfcz Je regarde ça


#8

Est ce que ça peut être ça :

fn_placeablesMenu.sqf
fn_placeablesMenu

placeables.hpp
placeables

Les majuscules peuvent jouer un rôle?


#9

Arma est sensible a la case.
Essaies de refaire les scripts avec un autre editeur pour voir (poseidon, notepad, …)


#10

Je suis en déplacement pour 1 semaine. Je reprendrais la résolution dès mon retour.


#11

Tu es de retour ? merci d’actualiser ton sujet :wink:


#12

Oui je suis de retour, dès que je rentre chez moi je m’y remets


#13

Toujours pas d’avancement dans l’affichage du menu.
Par contre, j’ai remarqué que quand j’appuie sur C, le message “Vous avez placez l’objet s’affiche”. Même sans cliquer sur le bouton ouvrir menu placeables. (Modifier, j’ai du déplacer le hint)


#14

Le problème est résolu.

Solution :

J’ai réécris tous les fichiers pas moi même sans faire de copier coller.

J’ai également supprimé cette partie du fichiers fn_placeablePlace.sqf :

if (typeOf (life_barrier_activeObj) != "") then { 
            _currentPos = getPosATL life_barrier_activeObj;
            detach life_barrier_activeObj;
            life_barrier_activeObj setPos[(getPos life_barrier_activeObj select 0), (getPos life_barrier_activeObj select 1), 0];
            life_barrier_activeObj enableSimulationGlobal true;
            life_bar_placey pushBack life_barrier_activeObj;
            life_barrier_active = false;
            life_barrier_activeObj = ObjNull; 
        };

#15

Parfait ! Je déplace


#16

Exactement ce que je pensais ! D ou les erreurs du 1er script envoye …


#17

Est ce que tu sais pourquoi ça fait ça? Car avec d’autres tuto je n’ai eu aucun problème :thinking:


#18

Va savoir … deja va comprendre pourquoi toi t as le probleme et d autre non !