Carte Grise LifeCfgVéhicles probléme


#1

Bonjour,

Quand nous allons dans le concessionaire de véhicule les information/Carte grise du véhicule ne s’affiche pas.

Cela viens du LifeCfgVehicles

Log :

21:35:09 ": LifeCfgVehicles class doesn't exist"
21:35:09 ": LifeCfgVehicles class doesn't exist"
21:35:09 Error in expression <cleWeightCfg;
_maxspeed = (_vehicleInfo select 8);
_horsepower = (_vehicleInfo s>
21:35:09   Error position: <select 8);
_horsepower = (_vehicleInfo s>
21:35:09   Error Diviseur nul
21:35:09 File core\shops\fn_vehicleShopLBChange.sqf [life_fnc_vehicleShopLBChange], line 102

Cordialement


#2

As tu installé les assurances ?


#3

Bonjour,

Non je n’est pas installer l’assurance

Cordialement


#4

A tu installer un script tierse prit sur un site en proposant gratuit ou payant ?


#5

C’est un véhicule moddé ?
Tu l’as rajouté toi dans le shop ?
Ça te le fait avec tous les véhicules ou que celui là ?


#6

Nous avons installer des script the programmer et nous avons etais avoir avec eux et cela viens pas de la. et Oui c’est des véhicule modder et nous avons sa avec tout les vehicules aucune carte grise s’affiche


#7

Cela peut venir de l’assurance auparavant l’assurance etais installer mais nous l’avons desinstaller


#8

tu as ajouté un vehicule dans Config_Vehicles.hpp c’est ça ?

car déjà, rien qu’en voyant ça cette ligne :

21:35:09 ": LifeCfgVehicles class doesn't exist"

les logs sont censé afficher un classname avant les “:”

Donc tu as un problème avec les shops, as tu bien installé tes véhicules moddé ?


#9

Bonjour,

Oui voici notre shop

https://pastebin.com/7ktTjkhi

Cordialement


#10

ligne 28
{ "c4hch_civ", "C" },

et tout ceux que t as ajoute genre:

//Véhicule Kris
class EC135GNlu {
    vItemSpace = 100;
    conditions = "";
    price = 250;
};

il manque des choses:
/*
* Vehicle Configs (Contains textures and other stuff)
*
* “price” is the price before any multipliers set in Master_Config are applied.
*
* Default Multiplier Values & Calculations:
* Civilian [Purchase, Sell]: [1.0, 0.5]
* Cop [Purchase, Sell]: [0.5, 0.5]
* Medic [Purchase, Sell]: [0.75, 0.5]
* ChopShop: Payout = price * 0.25
* GarageSell: Payout = price * [0.5, 0.5, 0.5, -1]
* Cop Impound: Payout = price * 0.1
* Pull Vehicle from Garage: Cost = price * [1, 0.5, 0.75, -1] * [0.5, 0.5, 0.5, -1]
* – Pull Vehicle & GarageSell Array Explanation = [civ,cop,medic,east]
*
* 1: ARRAY (license required)
* Ex: { “driver”, “” , “” , “” } //civilian, west, independent, east
* licenses[] = { {“CIV”}, {“COP”}, {“MEDIC”}, {“EAST”} };
* Textures config follows { Texture Name, side, {texture(s)path}}
* Texture(s)path follows this format:
* INDEX 0: Texture Layer 0
* INDEX 1: Texture Layer 1
* INDEX 2: Texture Layer 2
* etc etc etc
*
*/

     textures[] = {}; 

si y a pas de textures a mettre … sinon ton array est incomplet !


#11

Bonsoir, j’ai fait comem vous m’avez dit et modifier les choses : https://pastebin.com/2x8TAJLU Mais cela ne fonctionne pas :frowning:


#12

Avant de faire 50 000 modifs … commence par avoir un server qui tourne, apres tu ajoutes 1 vehicule et 1 seul. Une fois que t en a ajoutes 1 tu en places un 2eme et apres ca tu auras compris comment ca fonctionne , tu pourras en ajouter +


#13

Nous avons pas de probléme pour ajouter des véhicule ou retirer ! je pense que AltisDev est un forum d’entraide auquel de l’aide a trouver la solution peut étre proposer et pas a reprocher les choses sur la personne


#15

Tu ira voir avec eux parce que régler leur bug et leur non opti je passe :slight_smile: Je connais le fixe a ton soucis a eux de le retrouver dans leur beau bordel ^^


#17

Effectivement @jerem2002 il serait mieux de directement voir avec les concernés : The programmer, qui vendent du contenu payant, et que conformément à notre règlement, on ne devrait même pas apporter d’aide sur ces contenus payants, qui, devraient normalement être entièrement maintenus et assurés par leurs auteurs.


#18

Bonsoir,

Je vous comprend, Mais ce qui me trouve pas logique c’est que j’ai acheter aucun script qui toucher au config vehicule au lb garage, impound etc. Plusieurs hypothése viens que cela viendrai de l’assurance

Cordialement


#19

@brutalzic Je suis déjà allé voir ton collègue ARON sur ce sujet et nous avons déjà réglé le souci avec lui donc si tu as un reproche à me faire envoie-moi directement un message en privé (cela me paraît plus correct que de le faire ici).

@Joaquine C’est marrant car tu ne sais même pas le système qui l’a acheté (c’est évident que s’il achète un système pour cacher ses marqueur, ses magasins ne vont plus fonctionner) et avant de crier haut et fort que nos systèmes ne sont pas optimisés ou non fonctionnels renseignent toi…

@Tiiix De même, tu n’as aucune preuve que son problème est lié à nos produits surtout que son modèle n’est pas conforme au règlement mais bizarrement aucune remarque n’a été faites sur ça…

@jerem2002 Nous t’avons envoyé un message sur discord pour essayer de régler ton souci malgré qu’il n’y est aucun lien avec notre boutique. J’ai l’impression que tu n’es pas le bienvenu ici (client The programmer ) =)


#20

Je trouve cela dommage de dénigrer comme cela une boutique @brutalzic ! Chaqun est libre de penser ce qu’il veut, tant que cela ne deviens pas dénigrant, même remarque pour tout le monde d’ailleurs ! :slight_smile:


#22

Pour te répondre @Jean-Baptiste :

Je n’en ai effectivement aucune preuve exacte, car je n’ai pas été mettre le nez dans les logs. En revanche je n’accuse en rien votre collectif de quoi que ce soit, je dis simplement que des problèmes à vos outils doivent être traités avec vous et vous seul.
Maintenant, effectivement, au vu de l’erreur rencontrée, je ne pense pas que vos outils sont en cause.

@Joaquine tu pourrais peut-être développer ce que tu sais ? pour faire avancer les choses ? merci.

Maintenant, s’il s’avère que le problème est finalement de près ou de loin, lié à l’un des outils de The Programmer, plus aucune demande d’aide à ce sujet ne sera tolérée à l’avenir.

@Jean-Baptiste concernant le message de @brutalzic il a été modéré, tout comme les autres messages inutiles et à des fins exclusivement provocantes sur ce sujet.


#23

T inquiete je suis sur leur TS … comme je t ai dis je connais JB