Battleye bloque le chargement de fichiers ace.dll

Bonjour,

Je rencontre avec un problème avec Battleye

Ce que je fais

Je lance mon jeu depuis le launcher via steam, les mods du serveur Altislife auquel je veux jouer sont activés. Lors de ma connection, j’ai un message [ACE ERROR] (voir screen) et je suis kick.

Ce que je veux

Me connecter

Ce que j’obtiens

Voir screens : https://imgur.com/a/om7lehw

Version du serveur : v3.1.4.8 ? v5 ? v4.4r3 ?
Système d’exploitation : Windows

Ce que j’ai essayer :

Vérification des fichiers Arma 3
Mise à jour windows
CCleaner
Réinstallation d’Arma
Ouverture des ports steam (27015 à 27030)
Suppression des fichiers ACE qui posent problème et réparation via le launcher Arma
Suppression du dossier Battleye et vérification des fichiers Arma 3

Merci d’avance

@Vabramov Bonjour, Tu peut envoyer des logs et tu as téléchargé Ace3 où ?

Bonsoir :

Voici les logs d’Arma 3 Launcher : https://pastebin.com/dVk1TTWs

et d’Arma 3 : https://pastebin.com/nMEUVGGa

J’ai télécharger avec le mod workshop du serveur sur lequel je veux jouer : https://steamcommunity.com/sharedfiles/filedetails/?id=1570074499

Ensuite j’ai essayé avec une version GitHub : https://github.com/acemod/ACE3

J’ai aussi essayé en prennant les fichiers d’une personne qui parvient a jouer.

En fait, Battleye bloque toutes les DLL des mods sauf, si elles ont été acceptées par Arma, je ne sais pas si c’est le cas avec Ace mais je suppose que oui, si tu veux jouer juste entre potes désactive Battleye, si tu veux ouvrir ton serveur c’est plus compliqué mais il doit y avoir une version de Ace soit avec une DLL autorisée par Battleye soit sans DLL.

Le problème vient de chez moi, le serveur sur lequel je tente de jouer necessite battleye donc impossible de le désactiver, mais plusieurs centaine de personnes ont réussi a ce connecter avec la version de ace que je possède

@Vabramov Tu as parlé de ton problème au staff du serveur en question ? Sa vient peut être de ton anti-virus essaye de le désactivé de download Ace à nouveau et de lancer Arma 3 en mode administrateur !

Si ils utilisent battleye c est qu il y a la reconnaissance de mod par consequant, si tu n utilise pas la meme version que celle du server, ca ne fonctionnera pas.

Là c est un probleme de dll bloque qui est arrive a beaucoup de monde et qui c est debloque on ne sait comment (j en ai fait moi mm l experience).

J’ai parler de mon problème, mais impossible de trouver une solution. J’ai essayé en desactivant antivirus + pare-feu, mais ca ne change rien.

J’utilise la même version que le serveur, elle provient de leurs mods. J’ai vu des problèmes similaires sur d’autres forum, mais aucune solution qui fonctionne pour moi.

j ai jamais eu de solution, le probleme a disparu comme il est venu …

@Vabramov du nouveau ?

Oui,

La source du problème est ma connexion internet et en particulier Red by SFR.

En effet, en me connecter a un Wifi 4G de chez free (grâce à un partage de connexion d’un téléphone) ; il n’y a aucun problème, battleye ne bloque pas les fichiers, je peux jouer.

Le problème viens donc de ma connexion.

Je n’arrive cependant pas a trouver quoi faire.

J’ai essayé depuis le panel :

De déclencher les ports :
27000 à 2050 (les ports steam ? en UDP et TCP)
2302 à 2303 (ports arma 3 ?)

Et de transferer ces ports via “Transfert de port” vers mon adresse IP Locale.

Mais ca ne fonctionne pas. Je n’y connais pas grand chose dans ce domaine.

Merci d’avance

Regarde plutôt pour des règles NAT, le NAT permet de faire communiquer les réseaux publics avec les réseaux privés. Le transfert de port (en théorie, avec les box actuelles parfois…) permet plutôt de transférer une requête sur un port (depuis un réseau public), vers un autre port en écoute sur ton réseau privé ^^

Le transfert de port est très utilisé avec un reverse proxy. Imagine que tu ais 2 serveurs web sur ton réseau local et que tu souhaites leur attribuer deux nom de domain différents mais le même port (pour éviter de compliquer la tâche à un utilisateur), dans ce cas tu traiteras en fonction du domains/sous-domaine utilisé, les requêtes seront soit 80 (HTTP) soit 443 (HTTPS) et dans ton réseau local les ports de tes serveurs seront différents, c’est là que le transfert de port fera son travail^^

En espérant avoir pu t’aider et te faire comprendre la différence =)

Merci pour ta réponse, cependant sur le panel RED, il n’y a aucun onglet qui permet de configurer des règles NAT, ni même quoi que ce soit qui parle du NAT

Tu connais la version de ta box ?

Apparemment ils appellent cela “Déclenchement de port”.

Source : https://forum.sfr.fr/t5/Connexion-Internet-Fibre-WiFi/Comment-ouvrir-les-ports-pour-la-box-fibre-de-SFR-pour-Minecraft/td-p/1632505

Je ne connais pas la version de ma box, comme dit plus haut; j’ai déclencher les ports 27000 à 2050 (les ports steam ? en UDP et TCP) et
2302 à 2303 (ports arma 3 ?)

https://community.bistudio.com/wiki/Arma_3_Dedicated_Server#Port_Forwarding