Ajouter une musique d'introduction + Caméra en civil

Bonjour / Bonsoir dans ce tutoriel je vais vous apprendre à mettre une musique lors du spawn sur votre serveur altis life / arma 3 et une caméra cinématique en civil !

Commençons:

Aller dans votre mission (Altis_Life.Altis (Généralement)) puis mettez ces trois fichiers que je vais mettre en fichier joint ensuite aller dans core et dans fn_initCop.sqf et rajouter à la fin

 [] execVM "msgbienvenueCop.sqf";

Puis dans fn_initCiv.sqf vous rajouterez à la fin:

[] execVM "msgbienvenueCiv.sqf";

Pareil pour le fn_initMedic.sqf

[] execVM "msgbienvenueMedic.sqf";

(La caméra cinématique est disponible uniquement en civil, je vais vous mettre également un lien contenant quelque musique d’introduction pour votre serveur).

http://altisdev.com/index.php?/files/file/67-multi-musique-dintroduction-serveur/

PS: La musique que vous aurez choisi vous devrez la renommé en introSong.ogg)

Bien sûr vous devrez marquer le nom du fichier audio dans description.ext

Voilà tuto fini j’espère qu’il vous aura plu !

merci

Merci <3

tu peut en dire plus pour ajouter la musique car j’arrive a faire la cinématique mais la musique je n’arrive pas.

merci de ton aide :slight_smile:

diablopulsar pour la musique c’est simple :

Ouvres Description.ext et ajoutes cette class :

class introSong  
    {  
        name = "introSong";  //nom du son pour les scripts  
        sound[] = {"\sounds\introSong.ogg", 1.0, 1};   // Emplacement du fichier son, volume  
        titles[] = {};  
    };  

puis dans ton dossier /sounds/ tu ajoutes ta musique d’introduction qui s’appellera introSong et qui sera au format .ogg

Merci pour ton aide :slight_smile:

cool ^^

cela a fonctionner merci beaucoup

Bonjour moi quand j’entre dans mon serveur ca dis que introSong est manquant, Alors que je l’ai bien mis dans le dossier sounds,

faut mettre du format o.gg !

.ogg !!

Je le sais j’ai utiliser son pack de musique en .ogg

Bon merci j’ai réussi mon probleme étais au niveau du description.txt

Bonjour ou Bonsoir tout le monde,

j’ai le même problème que jobine.

Après multiples essais, quand je spawn en civil / EMS / cop après avoir choisi la ville ça met que le fichier introSong est manquant, pendant que la caméra descend. J’ai pourtant le fichier “introSong” en .ogg dans \sounds de Altis_Life.Altis.

Description.ext

class introSong  

{  

    name = "introSong";  

    sound[] = {"\sounds\introSong.ogg", 1.0, 1};  

    titles[] = {};  

};

En espérant pouvoir être aidé, Cryms.

Cryms

class Intro
{
name=“Intro”;
sound[]={"\sounds\Intro.ogg",1.5,1};
titles[] = {};
};

Dans ton msgbienvenueCiv.sqf

Ligne 14 :

player say "Intro";  

Voila :slight_smile:

Merci pour la réponse si rapide Pink :slight_smile:

Je vais tester cela tout de suite.

Cryms Pas de probleme !

Après plusieurs tests, ça ne marche pas.

Mais c’est étrange , j’ai mis Intro a la place d’introSong pour les scripts et ça ma met “introSong” manquant quand la camera charge l’arrivée sur la vue fps.

Help please !

Il faut savoir que je tourne en 3.1.4.6 sur Nitrado, serais-ce une incompatibilité ou je me suis juste raté un bon nombre de fois ?

Je met le screen et mes fichiers en pièces jointes pour plus d’infos.

Cryms.

Regarde ce que sa ecrit : IntroSong.

Il manque .ogg

Pink3vil C’est la ligne 14 des fichiers msg qu’il ne reconnait pas.

Qu’il y aie .ogg ou pas ne change rien pour ma part, j’ai même essayé de mettre la destination dans cette ligne.

Le < playsound “Intro” > est le problème ? Dans ce cas comment le résoudre ? “Intro” est le nom du script dans le description.ext non ? Soit ça viendrait du fichier description.ext ?

En attente de solution, Cryms.

Edit :

Cela pourrait venir des permissions, mais ce n’est qu’une supposition, je n’ai pas encore d’idée concrète.